Jump to content

Footage counter broken on Canon Auto Zoom 814?

Virginia Spoo

Recommended Posts


I've recently purchased a Canon auto zoom 814 (not the electric version) with two rolls of Ektachrome 160 from Ebay with a guarantee that it was completely functioning. I loaded in the correct voltage Wein Cell batteries for the exposure meter and AA batteries and decided to load in one of the rolls of film to shoot a test roll. I made sure I put the cartridge in the correct way and securely, and when I pressed the shutter lever it seemed as though it was filming. However, when I checked the footage counter the little needle didn't move at all, making me worry that none of my film is actually being exposed. I tried opening the compartment and taking out the cartridge and putting it back in, which I thought worked because I swore the needle moved a little when I pressed the lever, but I went out today to shoot and the needle didn't move at all the entire time I shot. Could the dial just be broken and the camera actually be exposing the film or is there some other issue with my camera/ none of the footage actually getting exposed??


Link to comment
Share on other sites

Could be either. I have a similar issue. I just marked the film with a sharpie at two different places, then ran it through to see if the film was advancing. It was. It's quite likely on a 30 plus year old camera that the needle is broken but everything else works.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...