Jump to content

Nizo S480 runs continuously


Nil Rodellas
 Share

Recommended Posts

Hi everyone,

I just received a Nizo S480. Once the shutter is pressed, the camera runs at the proper speed but does not stop when it is released.

I am aware there is a small lever on one side that acts as a continuous recording button, but it is disengaged. I've also dismantled the lower part (the black base where the handle hangs) and realised that it is not a mechanical problem of those switches.

I have taken apart the side covers, and from what I can observe, it seems as if the electromagnet that pulls a black lever does not disconnect after the release of the shutter.

I don't have the internal circuitry plan of the camera, neither servicing manuals.

Does anyone know if this problem is fixable, and how could it be fixed?

Thank you very much in advance,

Nil

P.S.: Of course one could use the camera using as shutter the on/off switch but this is far from practical.

Link to comment
Share on other sites

  • 1 month later...

Quite often it's a simple mechanical issue with weakness in the shutter trigger spring return, so fixable.  Sometimes it's an electrical issue of some kind, which is also fixable, since it's also usually something simple like a worn Reed Switch Contact.  Sometimes, either situation can be resolved via slight bending of the Trigger Return Spring [small needle nose pliers or strong tweezers] or the Reed Switch with tweezers. The return spring is often easily doable by anyone with some dexterity.  This issue has been addressed elsewhere on this site, and there are photos somewhere on this site in answers showing how to repair it and elsewhere on the internet.  If you're unable to sort it out, perhaps once you find the information, perhaps a buddy that has some repair skills can help you out.  Otherwise, it will mean sending it out for repair that alone will often set you back at least $150 plus shipping costs both ways.

Link to comment
Share on other sites

This happens rather often with these Silvery Nizo. Some components detoriate in the trigger/run circuit, likely a electrolyte capacitor.  A trick is to set to single frame and have on a intervalometer (or manual) and have it triggered for several hunderd frames. Somehow this will revive the component. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...