Jump to content

Search the Community

Showing results for tags 'arriflex 16 bl'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Cinematography Forums
    • General Discussion
    • News & Press Releases
    • Lighting
    • Camera Operating
    • AC's & DIT's
    • Grip & Rigging
    • Visual Effects Cinematography
    • Grading, DI and Telecine
    • Students and New Filmmakers
    • Cameras Systems and Formats
    • Lenses & Lens Accessories
    • Camera Accessories & Tools
    • Film Stocks & Processing
    • Books for the Cinematographer
    • Cinematographers
    • In Production / Behind the Scenes
    • On Screen / Reviews & Observations
    • Cine Marketplace
    • Business Practices
    • Jobs, Resumes, and Reels
    • Please Critique My Work
    • Regional Cinematography Groups
  • Not Cinematography
    • Producing
    • Directing
    • Sound
    • Editing
    • Off-Topic
    • Forum Support

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Skype


Location


My Gear


Specialties

Found 2 results

  1. Hi. I have 2 Arriflex 16BL's (4 mags), and every single time I load film into one, regardless of which magazine I use, this happens. See video posted here.. https://www.youtube.com/watch?v=PmZgD-JbLFI&feature=youtu.be&ab_channel=BrendanCollins Anyone have any idea? Motor seems to slow down with film as well, runs at normal speed when no mag is on the camera. Occasionally will run film just fine without this grinding noise. Both cameras do it. Never have had a problem before. I took the assembly out and I don't see any stripped or worn gears internally... SOS Thanks
  2. Happy New Year, everyone. This is my very first post to your informative forum. I am a retired ex-filmmaker looking for two "accessory" items for my beloved 16BL: 1. An OEM Arriflex carrying handle that attached "head on" to the front of the camera body just below the magazine housing and 2. A working, cosmetically clean 12 volt Cine 60 Battery belt with the four (4) female XLR pin openings I've been searching for the handle for quite some time and the majority of Cine 60 battery belts on Ebay are either not working, have five female XLR pin openings, or folks have no idea of what
×
×
  • Create New...