Jump to content
Sign in to follow this  
Lucien Xavier

Locam ii Issue

Recommended Posts

Hello All,

I purchased a locam ii recently, and have been learning how the bad boy works for a little while now. With that said, one issue I'm having is with the aperture plate of the camera.

I cannot, for the life of me, get the aperture plate out of the body. I've consulted the manual, which says to retract the pulldown claws and register pins, then to grasp the two knobs on the plate and pull straight outwards. I retract the register pins and the pulldown claws by using the film threading knob on the outside of the camera to get the pulldown claws out of the way, then I turn the register pin retract knob 90 degree clockwise, and pull the pressure plate back, and the aperture plate doesn't budge.

Any ideas why? Am I doing the wrong things to get the register pins and pulldown claws out of the way?

Thanks for anything,

Luc

post-60341-0-37453000-1363043294_thumb.jpg

Share this post


Link to post
Share on other sites

It's been a while, but there is a definite knack to the Locam. I remember sometimes being unable to reload. Then I picked up a wrinkle for it. Unhelpfully I can't remember what it was. Are you having trouble loading? It's the same thing, register pins not retracted.

Sorry but all I can suggest is systematic practice.

Does this help?

http://www.youtube.com/watch?v=xTHHLFDSebs

Edited by Mark Dunn

Share this post


Link to post
Share on other sites

It's been a while, but there is a definite knack to the Locam. I remember sometimes being unable to reload. Then I picked up a wrinkle for it. Unhelpfully I can't remember what it was. Are you having trouble loading? It's the same thing, register pins not retracted.

Sorry but all I can suggest is systematic practice.

Does this help?

http://www.youtube.com/watch?v=xTHHLFDSebs

 

Hey Mark, Thanks for the reply.

 

I've seen that video, and while it is insightful, unfortunately it doesn't help me. I haven't tried to load it yet. I'm still taking the camera apart and messing with the pressure and aperture plates. My issue isn't loading as much as it is just getting the aperture plate out. Around 1:47 of that video the fellow pulls the plate out no problem, I'm sure I've got the pulldown pins out of the way, and I think the register pins are out of the way as well, but unfortunately it doesn't pull out. It's driving me insane.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  


  • CineLab



    Media Blackout - Custom Cables and AKS



    Ritter Battery



    Tai Audio



    Rig Wheels Passport



    The Original Slider



    G-Force Grips



    Metropolis Post



    Broadcast Solutions Inc



    FJS International



    Serious Gear



    Paralinx LLC



    Wooden Camera



    New Pro Video - New and Used Equipment



    Just Cinema Gear



    Abel Cine



    Gamma Ray Digital Inc



    Visual Products



    Glidecam


    Cinematography Books and Gear
×
×
  • Create New...