Jump to content
Nate J Slaco

Bolex EBM troubleshooting

Recommended Posts

Hey,

 

I've got a Bolex EBM 16mm cam in pretty good condition that doesn't seem to run. I've tested it with multiple power sources and the red light turns on but the motor does not run when you press the button. I've tried to find people with Bolex knowledge in the Vancouver area but have had no luck! Any ideas as to what could be the problem? Or any suggestions as to my next course of action? Thanks in advance!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Gamma Ray Digital Inc



    Paralinx LLC



    FJS International



    Glidecam



    Media Blackout - Custom Cables and AKS



    CineLab



    Metropolis Post



    Ritter Battery



    New Pro Video - New and Used Equipment



    Broadcast Solutions Inc



    Rig Wheels Passport



    Tai Audio



    The Original Slider



    Wooden Camera



    Serious Gear



    Just Cinema Gear



    G-Force Grips



    Visual Products



    Abel Cine


    Cinematography Books and Gear
×
×
  • Create New...