Jump to content

Arriflex 16 SR 1 Camera has power but won't run!

Recommended Posts



I have an Arriflex 16 SR 1 that has stopped working.
When I flip the switch to run, the motor does not start and a red light comes on inside the view finder. The battery is fully charged tested it with a multi meter, and tried a different battery to be sure.

The owner’s manual says that a red light will come on in the view finder when the camera doesn’t have enough power to maintain a sync speed.

Has anyone else experienced this problem?
Does anyone know what the cause of this problem would be? Could it be that the voltage regulator is broken, or maybe the sync crystal is malfunctioning?
Does anyone know where a more detailed camera manual for this camera can be found? Like a troubleshooting or service and repair manual.



Link to post
Share on other sites

The SR manual


http://www4.uwm.edu/psoa_er/manuals/cameras/Arri-SR.pdf. I would see how much amperage your batteries putting out it could be 12 volts but very weak. Then check voltage at where it enters motor with your voltmeter see if it is making it there, if yes try powering the motor using jumpers to see if it will work independent of the system. If gets power with adequate amperage and voltage then see if it is mechanically free to spin.

Link to post
Share on other sites

Hi James,


I bought a new 12 Volt battery 4.5 Ah/4500 mAh with smart charger 9.6 Volt-18V NiMh from Du-All Cameras! I think it's the right battery pack for the SR 1 or not?


Thanks for the informations

Link to post
Share on other sites
  • 3 years later...



I know it's a while later but I am having the same problem with the same camera. Did you find a solution or what the problem was? I am also seeing the red light in the viewfinder and it runs for 1 second then stops when the switch is at start, everything else worked fine including the test button and battery is fully charged. 


Let me know ! would be super helpful 


Link to post
Share on other sites
  • 10 months later...

Hey there, I'm experiencing the same with my SR.

Did anyone ever figure out the problem or a fix? I'm confident it isn't a battery issue. Can't find any schematics of the board to narrow down the search if it's a broken circuit.

Any info would be much appreciated!

Link to post
Share on other sites

I’m not sure why people assume that if a camera as advanced as an SR won’t run, it must always be the same issue. If a car won’t start, is it always because the distributor cap is cracked?

There are multiple reasons why a camera like this might not run: component failure, broken timing belt, movement lubrication, sticky motor brushes, loose screw in a critical coupling etc. If the most common causes (not enough power due to low battery capacity or highly resistant cable, blown fuse under the see-through cover) can be ruled out, it probably needs to go to a specialist. These aren’t typically DIY repair cameras.



Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...