Jump to content
Max Kirk

Krasnogorsk-3 loading issues (video)

Recommended Posts

Hi all,

Just got a  Krasnogorsk-3, having an issue with the film slipping up the sprockets as I run it through (at least I think this is the issue but may be wrong)

Seems like the sprocket roller isn’t attatched properly on the on the top side? I've tried adjusting with the position of the release pins but even when the film seems to be proplery in place,  the film still shifts up and then pulls out the pressure plate as soon as I start to shoot..

Very new to this so any help would be much appreciated,

Thanks so much.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • The Original Slider



    Tai Audio



    Rig Wheels Passport



    FJS International



    Serious Gear



    New Pro Video - New and Used Equipment



    Wooden Camera



    CineLab



    G-Force Grips



    Paralinx LLC



    Ritter Battery



    Abel Cine



    Broadcast Solutions Inc



    Media Blackout - Custom Cables and AKS



    Glidecam



    Just Cinema Gear



    Gamma Ray Digital Inc



    Visual Products



    Metropolis Post


    Cinematography Books and Gear
×
×
  • Create New...