Jump to content

K100 Service Manuals Available Here


 Share

Recommended Posts

A couple people have requested that I send them these service manuals. They are difficult to email, so I'm posting them on my FTP server. Here are the urls. Anyone who reads this post is welcome to download and use the pdfs.

 

 

http://suburbs.com/k100/k100x1.pdf

http://suburbs.com/k100/k100x2.pdf

http://suburbs.com/k100/k100x3.pdf

 

The K100 is my favorite camera:

1) It has an insanely long spring

2) It has a nice bright viewfinder

3) It fits right into a small video bag because it's got no weird or large appendages

4) It's got decent registration - provided you don't buy one with a worn out pressure plate/aperture plate.

5) It's sufficiently sparkly that people think it's cool, but it's not so sparkly that it draws the kind of crowd a Bolex draws.

On the downside:

1) It doesn't use B&H finders. The widest K100 finder I've found is 14mm. That gets me pretty close to the 10mm Kern lens I like to use. I just ignore the frame lines and consider the vertical tangents of the circular field of view as left and right edge of 4:3 frame.

2) It sinks if the raft your on capsizes.

 

Long live film!

 

I tried to edit title but site rejected my edit. I am therefore posting with correct title.

  • Upvote 1
Link to comment
Share on other sites

This is very helpful! I bought a K100 Turret the other day but it doesn't run at all. I will be opening it up soon. If I can't find out what's wrong with it I might send it to someone who can. If it's a broken spring I will just keep it for spare parts, for instance the pressure plate. I agree entirely about the look of the K100 compared to a Bolex. With a Bolex, you do get a lot of looks and curious passers-by stopping and wondering what on earth that amazing looking shiny contraption is. The K100 from a distance could almost pass as some kind of (large) digital camcorder. I like that.

Link to comment
Share on other sites

... That is, the single lens version of the K100 looks a bit like a large camcorder. The Turret model is (to me) a somewhat strange-looking beast, and looks a bit like an old studio TV camera. I don't like how the lenses on the lower part of the turret actually droop down a bit due to the curve of the turret front plate. It's functional, but it's not a great look in my opinion.

Link to comment
Share on other sites

Yes that's right, it's for a functional reason. I think it's a great camera and I'm really keen to get mine working, if I can.

The service manual mentions replacing a 'cord' between the shutter and film compartment with a bead of sealant. It also mentions different types of lubricating oil. The sealant and oil are identified only by a Kodak product or parts number. Can anyone advise what sealant and oil could be used? I'm not very handy when it comes to fixing things so, for me, this kind of thing is a bit of a mystery so far.

My K100 is entirely jammed. I do get the impression though that the spring motor is okay as I can feel the spring being tensioned as I turn the winding lever. The camera just won't run or do a thing when the exposure lever is turned to its various positions. Also, the shutter is in the open position -- which makes me wonder if the problem is located somewhere in the shutter and claw area at the front of the camera.

 

Link to comment
Share on other sites

It is one of my favourite cameras too.

If you can sense the tension in the spring as you wind and the spring meter is moving as you wind then the problem is most likely the shutter getting stuck. Look for signs if the camera has been opened before, the front plate slides out once the screws are removed, there is usually a sealant too that you have to cut. As we take the front plate off the shutter can 'accidentally'  bend very easily, I have found that a bent shutter is the main reason if the camera winds but wont run, the shutter can be easily straightened out.

Pav

Edited by Pavan Deep
  • Upvote 1
Link to comment
Share on other sites

Thanks for the input Pavan. I'm encouraged that it might only be a simple problem. The service manual says that a completely jammed camera can be caused by improper loading of the film (a previous owner could have done this) which can cause the claw follower to disengage "from the cam track" (page 2 of the third document that Dennis posted, above). Could you let me know what type/brand of sealer and lubricating oil you use for repairing these cameras? I'm still interested in getting you to do a S16 conversion on a K100 some day (after I get some other gear I need first).

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

Forum Sponsors

Visual Products

DMX-iT

FJS International

Film Gears

CineLab

Wooden Camera

Gamma Ray Digital Inc

Broadcast Solutions Inc

Serious Gear

Metropolis Post

Abel Cine

Tai Audio

New Pro Video - New and Used Equipment

Cinematography Books and Gear



×
×
  • Create New...