Jump to content
Kevin Walls

Canon 514 XL-S - Stopped Working

Recommended Posts

Hey folks,

 

I've been shooting on my Canon 514 XL-S for about a year or so now and I haven't had any problems with it. I'm also very new to using film cameras, so I am a bit clueless.

 

I was in the middle of shooting today and the camera stopped working out of the blue. At first I thought it was the batteries but, when I tested them, they were still full of energy. The contacts on the camera were clean and free of corrosion but I was getting nothing out of the camera.

 

I had a small digital camera mounted to the top of the 514, so I have a sound recording of the moment the camera stopped working.

 

https://soundcloud.com/kevinwalls/super-8-canon-514-xl-s

 

Does anyone know what could have happened?

 

Thanks!

 

EDIT: When I turn the switch to the 'R' position I can hear a faint high pitched whining coming from the camera.

Edited by Kevin Walls

Share this post


Link to post
Share on other sites

It might be the cartridge is jammed. A somewhat common occurrence with negative stock. Try taking it out and putting it back in again. That works for me. Be sure to take note of the film counter, as it will reset once you take out the cart. Beyond that, the belts, if any or gears may be jammed. The easiest and cheapest fix is to purchase another camera.

Share this post


Link to post
Share on other sites

I tried taking the cartridge out and putting it back in but it still refused to run. It was a pretty cold day. I'm not sure if that had anything to do with it.

 

Thanks, Chris! I appreciate your reply. Having a look for a new one now.

Share this post


Link to post
Share on other sites

No, its not working without the cartridge either.

 

The cue light comes on, and stays on, when I turn the switch to the R position. Also, the battery light isnt coming on when I press the battery check button. However the batteries are brand new and are successfully powering my small led light panel.

Share this post


Link to post
Share on other sites

Change the batteries, the motor will require more power than the LED cue lamp. Only issue ever experienced with a 514xl-s is the battery compartment to camera contacts, never had a motor failure, so change them batteries, are they Duracell's?

Share this post


Link to post
Share on other sites

I tried changing the batteries but still no luck. I believe it is Duracell Power Plus AAs I am using. I was considering trying to source an 9V power pack to use as an alternative.

Share this post


Link to post
Share on other sites
My considered opinion is that if it went ping mid-shot, and it's been working fine hitherto, then it's chuffed. You mention a whine so perhaps it's something mechanical. You may need the hands of a surgeon to fix it, but I would certainly have a look. I'm sure there are some resources out there.

Share this post


Link to post
Share on other sites

Just listened to the sound bite, don't like the sound of the camera, try inserting the batteries and wave the camera around, turn the camera upside down, see if the hand grip to camera body is making poor contact, wiggle the handgrip around, operate the camera with the hand grip folded down and up next to the camera body. If that doesn't work, look for another camera.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Visual Products



    Serious Gear



    Glidecam



    Broadcast Solutions Inc



    Ritter Battery



    Gamma Ray Digital Inc



    Tai Audio



    Paralinx LLC



    Wooden Camera



    Rig Wheels Passport



    Abel Cine



    Metropolis Post



    New Pro Video - New and Used Equipment



    Media Blackout - Custom Cables and AKS



    CineLab


×
×
  • Create New...